This project is read-only.

The problem with using the memory.

Mar 20, 2013 at 9:58 AM
Edited Mar 20, 2013 at 12:54 PM
Hi! while doing a test application noticed that ModernUI not free the memory. Roughly speaking, if switching back and forth between the elements of a surprising number of occupied memory is increasing. and judging by the control logic created and only loaded-unloaded. But, by making use of memory is always surprising number growing? I try to make something like this:
<Grid Style="{StaticResource ContentRoot}">
     <! - TODO: set @ SelectedSource ->
     <mui:ModernFrame KeepContentAlive="False">
     <mui:ModernTab Layout="List" SelectedSource="/View/Test1.xaml">
         <mui:ModernTab.Links>
             <mui:Link DisplayName="some 1" Source="/View/Test1.xaml" />
             <mui:Link DisplayName="some 2" Source="/View/Test2.xaml" />
             <mui:Link DisplayName="some 3" Source="/View/Test3.xaml" />
         </ mui: ModernTab.Links>
     </ mui: ModernTab>
     </ mui: ModernFrame>
</ Grid>
but nothing has changed.

can tell me what to do to not waste memory for nothing?
Mar 20, 2013 at 12:53 PM
also has a strange behavior when unload (switch to other menu items) control is loaded again, and then double unloaded.
Mar 20, 2013 at 12:58 PM
Although it is probably due to the fact that I have used in the load and Unload Events. When I removed this code, as if the memory was freed
Mar 20, 2013 at 5:53 PM
Is your initial issue still valid? or also resolved when removing the event handlers?
Mar 20, 2013 at 9:05 PM
Edited Mar 20, 2013 at 9:05 PM
Well, most likely issue resolved. helped ModernFrame.
one question, whether I use the Modern Frame?